The migration helper tool fails to connect to CI360 with "I/O error on GET request... Connection timed out..."


When you run the migration helper tool to move campaigns from SAS® Customer Intelligence version 6.x to CI360, the following error messages occur in the SASCustIntelCore6.x.log:

on.service.IntegrationServiceGatewayImpl - getTenantFromCredentials: user="XXX", apigwUrl=https://extapigwservice-eu-prod.ci360.sas.com
on.service.IntegrationServiceGatewayImpl - setupProxy(SID,URL,String,boolean) proxyUser not set so not using proxy server and setting default Authenticator to null
on.service.IntegrationServiceGatewayImpl - About to invoke URL: GET /marketingGateway/tenant

ERROR [tomcat-http--337] [6339ccc38bddf315:12c6f34:1a059fdd3a4:-5254] [sas] clientIP[10.xxx.x.xxx] nalytics.crm.integration.client.RestCall - Received failed exception: I/O error on GET request for "https://extapigwservice-eu-prod.ci360.sas.com/marketingGateway/tenant": Connection timed out: connect; nested exception is java.net.ConnectException: Connection timed out: connect
org.springframework.web.client.ResourceAccessException: I/O error on GET request for "https://extapigwservice-eu-prod.ci360.sas.com/marketingGateway/tenant": Connection timed out: connect; nested exception is java.net.ConnectException: Connection timed out: connect 

This error message indicates that the proxy user is not set. As a result, the connection is done using the default non-proxy settings.

When this issue occurs, check whether you are using a proxy server for the connection to CI 360. Verify that the proxy parameters (proxyHost, nonProxyHosts, ProxyPort, and so on) are set in the utilities.ini file when running the utility.  

Cause

The error message in the SASCustIntelCore6.x.log shows a timeout after about 40 seconds. When SAS Customer Intelligence makes an HTTP GET call to APIGW endpoint that retrieves the tenant's name, it implies that SAS Customer Intelligence is not able to connect to CI360. 

Resolution

If you use proxy, the proxy parameters are set as JVM options in the start-up script. Restart the servers if you add the parameters in setenv.sh/bat or wrapper.conf file. 

Note: SAS recommends that you create a copy of the files prior to making any changes.

-Dhttps.proxyHost=<host or IP>
-Dhttps.proxyPort=<port #>
-Dsas.proxyUser=<user name>
-Dsas.proxyPassword=<user passwd>
-Dhttps.nonProxyHosts=<hosts or IPs>
-Dhttp.nonProxyHosts=<hosts or IPs>

The .ini for the utility is in the root path of the utility. If using a proxy, then the proxy server settings above should be set there as well (following existing format in .ini).

<SASHome>/SASCustomerIntelligenceUtilities/6.6/sasciutils.ini