A datetime-field overflow error might occur when your write a date to a Microsoft SQL Server table


When you use SAS/ACCESS® Interface to ODBC, SAS/ACCESS® Interface to Microsoft SQL Server, or SAS/ACCESS® Interface to OLE DB to write a date to a Microsoft SQL Server table, the following error might occur:

ERROR: Datetime field overflow

This error occurs when you try to write a date that is outside the valid range of dates for the Microsoft SQL Server datetime field. The datetime field can store dates from January 1, 1753 through December 31, 9999. To correct the error, make sure you are using a date within that range.