The SASĀ® Model Implementation Platform web application might not start and returns "Could not generate OTP..." when the SAS Trusted User is external


After installing and configuring the SAS Model Implementation Platform middle tier, you could encounter the following error in the SASServer11 log:

ERROR com.sas.svcs.authentication.helper.SpringSecurityContextFactory - Could not generate OTP for sastrust@saspw. No trusted user set for SecurityContext generation.

The issue occurs when you select an external account for the SAS Trusted User instead of an internal one such as sastrust@saspw during the initial configuration of SAS.