An error occurs after you install Hot Fix F7P001la for SAS® High-Performance Risk


Execution for the SAS Model implementation fails after you apply Hot Fix F7P001 to SAS High-Performance Risk Server. The failure occurs when you apply Hot Fix F7P001la (which is part of the F7P001 container hot fix) individually rather than as part of the container hot fix. When the failure occurs, the following error message is generated:

NOTE: The SAS Log will include the journaling of SYSTEM events.

NOTE: The risk project specifications will be loaded from 'miprslt'.

NOTE: The Risk Environment was successfully loaded from 'miprslt' (version 4.2 (EX:131), encoding=utf-8).

NOTE: The grid run is starting.

NOTE: The HPRISK procedure is executing in the distributed computing environment with 37 worker nodes.

ERROR: The protocol of the HPRISK engine on the grid (version 4.2HF1 (PR:574)) does not match the server (version 4.2HF4

(PR:578)).

. . .additional similar error lines. . .

ERROR: The protocol of the HPRISK engine on the worker node (version 4.2HF1

(PR:578)).

WARNING: The item store

/apps/config/Lev2/AppData/SASRiskWorkGroup/groups/mipgroup/SASModelImplementationPlatform/output/run_ins
tances/test/results/test.rskcdesc information is not complete. The item store is being deleted.

NOTE: The SAS System stopped processing this step because of errors.

NOTE: PROCEDURE HPRISK used (Total process time):

To resolve this issue, you need to apply the G2F003 container hot fix for SAS High-Performance Risk 4.2. This hot fix resolves the issue because it contains the updates for superseded Hot Fix F7P004 for SAS High-Performance Risk Server Component 4.2.