Running the update configuration from the SAS® Deployment Manager fails on the Midtier cluster


When you attempt to update the configuration from SAS Deployment Manager on the second middle-tier node in a cluster configuration by following instructions in Maintain a Horizontal Cluster Member, the following errors might occur.

In Stage 1-Step 2 (SAS® Web Application Server Node Configuration), an error similar to the following might occur:

2026-03-02 17:36:23,947 [main] ERROR com.sas.sdw.SDWExceptionHandler - com.sas.sdw.SDWException:
An unexpected error occurred. Please refer to
/sas/mid/sasconfig/Lev1/Logs/Configure/tcsclusterc_updateConfigure_2026-03-02-17.36.15.log
for more details.

at java.base/jdk.internal.reflect.DirectConstructorHandleAccessor.
newInstance(DirectConstructorHandleAccessor.java:62)

........................................
Caused by: groovy.lang.MissingMethodException: No signature of method:
com.sas.sdw.utils.BeanWrapper.setPropertyValue() is applicable for argument types:
(String, String) values: [tcServerVersion, 9.47]

Possible solutions: setPropertyValue(java.lang.String, java.lang.Object),
getPropertyValue(java.lang.String)

When you execute the SAS Deployment Manager in console mode on Linux, the shell shows the following error:

Linux shell with error

Cause

The problem is caused by the sas.appserver.config.jar files in Hot Fix P6T002 for SAS Web Application Server 9.53. You encounter the issue if you applied this hot fix and then performed an update of the existing configuration (UEC) on both 25w25 and 25w38.

Workaround

This issue is fixed in the latest released version of the hot fix, and you can no longer download Hot Fix P6T002. 

To fix an affected environment, perform the following steps:

  1. After failing the "Update Existing Configuration" in a secondary node, stop all servers in the primary and secondary nodes.
  2. Install Hot Fix P6T003pt on the primary node. 
  3. Install Hot Fix P6T003pt on the secondary node.
  4. Rebuild and redeploy web applications on the primary node.
  5. Turn servers on again on the primary node.
  6. Delete and back up the /SASHome/SASVersionedJarRepository/eclipse/com.sas.app.launcher.cacheFile file on the secondary node.
  7. On the secondary node, run the Update Existing Configuration option again.

These additional steps might be necessary: