The sas-svi-datahub log contains "Data store... was not found in the credentials service, manual intervention and/or repair maybe required"


When you use SAS® Visual Investigator, there are multiple scenarios where jobs fail and/or data store errors occur. This article covers some scenarios you might encounter and offers a solution. 

Table of Contents

Scenarios

There are three scenarios in which this issue occurs. 

Scenario 1

When you try to create a new internal entity in SAS Visual Investigator, it either keeps loading indefinitely, or an error similar to the following (or another generic error) occurs:

A system internal error occurred. Please contact support team with details

Scenario 2

When you run an indexing job in SAS Visual Investigator, the job fails an error message similar to the following on the Jobs tab of the user interface when you highlight the failed task:

DataStoreException: Unhandled exception for data store “ALERT_STORE”:
“500: “ {“httpStatusCode: 500, “errorCode”:“DH900”, “message”:”A system
internal error occurred. Please contact support team with details…

Scenario 3

When you try to import configuration in SAS Visual Investigator, the configuration import job fails with the following error on the Jobs tab of the user interface when you highlight the failed task:

The data store name with "DEFAULT_STORE" was not found

Log File Error

In any of these scenarios, the sas-svi-datahub log that is generated shows the following error:

{"version":1,"timeStamp":"2025-08-07T04:53:19.629Z","level":"error","source":"sas-svi-datahub",
"message":"[__default__] Data store DEFAULT_STORE exists in the database, but was not found in the credentials service, manual intervention and/or repair may be required.","properties":{"logger":"com.sas.fcs.datahub.datastore.management.dual.
DualPersistence","thread":"https-jsse-nio-8080-exec-6","username":"sas.svi-indexer"},
"messageParameters":{"0":"__default__","1":"DEFAULT_STORE"}}

{"version":1,"timeStamp":"2025-07-29T17:56:19.708Z","level":"error","source":"sas-svi-datahub",
"message":"[__default__] Data store ALERT_STORE exists in the database, but was not found in the credentials service, manual intervention and/or repair may be required.","properties":{"logger":"com.sas.fcs.datahub.datastore.management.dual.
DualPersistence","thread":"https-jsse-nio-8080-exec-8","username":"sas.svi-alert"},
"messageParameters":{"0":"__default__","1":"ALERT_STORE"}}

Cause

This issue usually occurs when the DEFAULT_STORE data store credentials that are stored in the credentials service of the SAS® Viya platform are missing, inaccessible, or in an unrecoverable state. The credentials are in this state typically due to an out-of-sync or unsupported backup and restore of the database and/or consul, which results in mismatched credentials. The DEFAULT_STORE data store is used by the Data Hub service to internally manage SAS Visual Investigator data such as internal entities and relationship links. 

The issue might also occur after you delete and regenerate the data store credentials after a tag mismatch error. See KB0040307 for details about the tag mismatch error.

Solution

  1. Unzip the script to regenerate the credentials from scratch with PUT requests via curl.

  2. Replace only the hostNameURLGoesHere, SASAdministratorsUserNameGoesHere, and passwordGoesHere strings in the script. Leave everything else as it is.

    • You can specify sasboot or a user with SAS Administrators group membership for SASAdministratorsUserNameGoesHere and its password for passwordGoesHere.

    • The hostnameURLGoesHere string is supposed to point to your Ingress Controller's hostname in http(s)://<hostname> format.

  3.  Run the script.

  4. Restart the sas-svi-datahub and sas-svi-alert pods.