SAS® Visual Investigator search results do not match the selected filters when you change filters quickly


When you use a filtered search in SAS Visual Investigator, the results might not match the filters that are currently selected.

In the Search view, if you select or clear filter check boxes (facets) quickly while the results are still loading, the objects displayed in the Results table can reflect an earlier filter state instead of the most recent one. For example, you might select only Alert in the filter panel, but the results display both Alert and other object types.

This behavior was reported in SAS® Visual Investigator 10.8 Hot Fix 14 and earlier.

The same issue was previously observed in the SAS® Viya® platform (and was in 2024.06).

Cause

When you change filters, SAS Visual Investigator sends search requests to the SAND service.

In the affected releases, multiple search requests can be sent and completed out of order if you change filters quickly. The results from an earlier request can overwrite the results from the latest filter selection, which causes the mismatch between the Filter panel and the Results table. 

Workaround

To circumvent this issue, do either of the following:

Method 1: Upgrade to a Version That Contains the Fix 

You can circumvent this issue by debouncing the search calls so that only the final filter change triggers a search.

After you apply the fix, verify that the results match the selected filters when you change filters at normal speed.

Method 2: Avoid Rapid Filter Changes Until You Apply the Fix

If you cannot upgrade immediately, use the following workaround:

Additional Information

If you contact SAS Technical Support about this issue, provide the following information: