A Purchase Order Plan might fail to optimize when a store does not exist in a prior delivery in SAS® Size Optimization


A Purchase Order Plan in SAS® Pack Optimization might fail to successfully optimize with an Optimization Failed plan status for multiple deliveries. In addition, when you review the Purchase Order list of Buys for that Purchase Order Plan on the Buys tab, the Buy Name in the list displays an Optimization Failed status. Note that the status might also be displayed in black text with no link to the associated warnings or errors.

Cause

In a scenario where a store does not exist in a prior delivery, but the store does exist in a subsequent delivery, the Pack Engine results in a null value. Specifically, when you set up the deliveries as follows:

Workaround

The hot fix for this issue allows the Pack Engine to proceed with completing the Pack Recommendation for subsequent deliveries where a store is not present in a prior delivery.