Log lines that contain the word "password" are replaced with "SENSITIVE INFORMATION REDACTED"


You might encounter an issue when using log4SAS logging where entire log lines that contain the word "password" with “SENSITIVE INFORMATION REDACTED”, even when no sensitive data is present. This occurs in the following environments:
This occurs when SAS programs are executed through SAS servers configured with log4SAS logging.

Cause

The issue occurs when SAS log lines are routed through log4SAS / IOM logging, typically when servers are started with options such as the following: -logconfigloc SAS-configuration-directory/Lev1/SASApp/server-name/logconfig.xml -logparm "rollover=session"

This issue applies to multiple SAS servers, including the following:
  • Batch Server
  • Workspace Server
  • Pooled Workspace Server
  • Stored Process Server

In this scenario, the following occurs:

  • SAS log lines are intercepted and processed by the log4SAS framework.
  • If a log line contains the word “password” (case-insensitive), the entire line is replaced.

Workaround

To work around this issue, disable log4SAS/IOM logging for the affected server to prevent excessive redaction. This is typically done by removing the -logconfigloc (and associated -logparm) options from the server startup configuration.

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