The error 'Error: MySQL client ran out of memory' occurs when you use SAS/ACCESS® Interface to ODBC


When you query the MySQL database with SAS/ACCESS Interface to ODBC, you might receive an error similar to the following:

[MySQL][ODBC Driver]MSQL client ran out of memory

To fix this error message, you must change a setting in your ODBC data source, as follows:

  1. Navigate to your ODBC administrator (Start ► Settings ► Control Panel ► Administrative Tools ► Data Sources (ODBC)).
  2. Highlight the ODBC data source and choose Configure.
  3. Click the Advanced tab, and then select the Flags 2 tab. Place a check mark beside Don’t Cache Result.
  4. Click OK.