DataFlux Data Management Studio and DataFlux Data Management Server cannot read data sets that are created with SAS 9.4. When you are trying to read a SAS 9.4 data set, an error similar to the following occurs:
In the log, you see the following error:
ERROR DF.DAC - Operation failed: [42S02] Table "..." does not exist or cannot be accessed (-2118139637); [HY000] BASE driver, Table ... does not exist or cannot be accessed or created (-2118137834)
ERROR DF.DAC - set connect attr current catalog failed: [3D000] Invalid catalog name DICTIONARY (-2130708380)
This error is due to a change in the data set format with SAS 9.4. The current workaround for this issue is to add the following to the LIBNAME statement when you create the data set: