The SAS® Web Server configuration fails with a FileNotFoundException error for the sas-environment.xml file during an update


When you are performing an update, SAS® Deployment Manager fails during the SAS Web Server configuration, and the following error appears in the vfabrcersvrc_updateConfigure_date-time-stamp log file:

Caused by: java.io.FileNotFoundException: Source
'/SAS-configuration-directory/Lev1/Web/Common/sas-environment.xml' does not exist

This issue happens when SAS Web Server and SAS Web Application Servers are on separate machines. This issue can also happen when you are performing the Update Existing Configuration task on a middle-tier cluster node.

To work around this issue, follow the steps below:

  1. Copy the SAS-configuration-directory/Lev1/Web/WebServer/htdocs/sas/sas-environment.xml file from the SAS Web Server machine to the SAS-configuration-directory/Lev1/Web/Common directory on the machine where it fails.
  2. Click Retry in the SAS Deployment Manager error window.