Login attempts to SAS® Cost and Profitability Management might fail with a "Failed to open or create memory mapped file for model 0" message


In SAS® Cost and Profitability Management, login attempts can fail with the following error message:

Failed to open or create memory mapped file for model 0

Cause

This error typically occurs something happened to the template model file, which is located in the model storage path in a directory named M0.

Resolution

To resolve this issue, force the server to create a new copy of this template model file by completing the following steps:

  1. Stop the object spawner.
  2. In the model storage path, rename the M0 directory to M0_old (that is, <SASConfig>\Lev1\SASApp\ABMServer\Models\Model0).
  3. Start the object spawner.

Once you restart the object spawner, users should be able to log on to SAS Cost and Profitability Management successfully. If this workaround resolves the issue, you can safely delete the M0_old directory.

Note: You do not need to back up first since you replace only the template model file. 

In addition, if (after following these instructions) the same error message occurs for another model, the Operating System permissions on the model storage path might cause this issue.