In SAS® Cost and Profitability Management, login attempts can fail with the following error message:
Failed to open or create memory mapped file for model 0
This error typically occurs something happened to the template model file, which is located in the model storage path in a directory named M0.
To resolve this issue, force the server to create a new copy of this template model file by completing the following steps:
Once you restart the object spawner, users should be able to log on to SAS Cost and Profitability Management successfully. If this workaround resolves the issue, you can safely delete the M0_old directory.
Note: You do not need to back up first since you replace only the template model file.
In addition, if (after following these instructions) the same error message occurs for another model, the Operating System permissions on the model storage path might cause this issue.