Connecting to Process Manager from SAS® Management Console might fail with "The interface to the scheduling server is not available"


When you try to connect to IBM Spectrum LSF Process Manager from SAS Management Console, the following error might occur:

The interface to the scheduling server is not available. Contact SAS Technical Support.

Although this message can occur for other reasons (such as the Process Manager not running, a problem with the network path between SAS Management Console and the server, or an authentication failure), the message can also occur if the authentication process takes longer than expected.

Cause

A time-out is configured for the connection to Process Manager in the SAS Management Console Schedule Manager plug-in. If the authentication process exceeds this time-out, the connection can fail. This time-out was set to five seconds at SAS® 9.4M6 (TS1M6).

If an issue occurs with Process Manager's authentication configuration or your authentication uses external services like LDAP, delays could be introduced into the authentication process, which causes you to reach this time-out. Depending on the failure, this could mean that the error in SAS Management Console surfaces intermittently.

Workaround

To work around the issue, ensure that Process Manager authentication consistently takes less than five seconds to complete. 

The hot fix planned for this issue extends the time-out to 60 seconds.