SASLogon returns error 500 instead of 401


Calling the SAS® Micro Analytic Service Heartbeat in the SAS® 9.4M8 (TS1M8) release with and invalid or expired ticket fails with error 500 instead of 401.

Here is an example: https://hostname/SASMicroAnalyticService/rest/modules/masheartbeat/steps/check_v1?ticket=ST-notavalidticket.

As a result, an error similar to the following might occur in SASLogon:

org.apereo.cas.ticket.InvalidTicketException
        at org.apereo.cas.ticket.registry.AbstractTicketRegistry.getTicket(AbstractTicket
Registry.java:76)
        at org.apereo.cas.ticket.registry.AbstractTicketRegistry$$FastClassBySpringCGLIB$$d3c
67a11.invoke(<generated>)
        at org.springframework.cglib.proxy.MethodProxy.invoke(MethodProxy.java:209)
        at org.springframework.aop.framework.CglibAopProxy.invokeMethod(CglibAopProxy.java:377)
        at org.springframework.aop.framework.CglibAopProxy.access$000(CglibAopProxy.java:76)
        at org.springframework.aop.framework.CglibAopProxy$DynamicAdvisedInterceptor.intercept
(CglibAopProxy.java:694)
        at com.sas.svcs.security.authentication.ticket.registry.TicketRegistryDecorator$$
EnhancerBySpringCGLIB$$e30fa477.getTicket(<generated>)

There is no workaround for this issue.