SAS® Central Authentication Service (CAS) returns HTTP Status 401 when requesting the service ticket using :443


Calling the SAS® Micro Analytic Service Heartbeat by adding port 443 in the URL fails with error 401.

For example, calling https://hostname:443/SASMicroAnalyticService/rest/modules/masheartbeat/steps/check_v1 fails with the following:

Invoke-WebRequest : HTTP Status 401 – Unauthorizedbody {font-family:Tahoma,Arial,sans-serif;} h1, h2, h3, b {color:white;background-color:#525D76;} h1 {font-size:22px;} h2 {font-size:16px;} h3 {font-size:14px;} p {font-size:12px;} a {color:black;} .line {height:1px;background-color:#525D76;border:none;}HTTP Status 401 – Unauthorized