Indexing jobs fail with "The index for the object could not be created" in SAS® Visual Investigator


Indexing jobs in SAS Visual Investigator fail with an error message similar to the following:

The index for the object <objectName> could not be created.

In addition, in the svi-indexer logs, error messages similar to the following occur:

Encountered an error executing step createNewIndex in job objectTypeChildJob\ncom.sas.svi.indexer.exception.IndexerException: The index for the object \"PTY\" could not be created.
Caused by: org.springframework.web.client.HttpServerErrorException$InternalServerError: 500  on POST request for \"/svi-sand/admin/indices/PTY\": \"{\"errorCode\":95001,\"message\":\"An error occurred during a request to a different service. Please contact your application administrator if this issue persists.\"

In svi-sand logs, error messages similar to the following also occur:

[REQUEST_HANDLING_ERROR] [d0bad391-b80e-445d-89b5-1e506bf6b38a] The request to the URI /svi-sand/admin/indices/PTY resulted in an error. Refer to the related log entries for more information.
[REQUEST_HANDLING_ERROR_DETAILS] [d0bad391-b80e-445d-89b5-1e506bf6b38a] Error: key: OPENSEARCH_ERROR.msg resource bundle: svi-sand-opensearch message: OpenSearch returned an error: Code: 429. Error: circuit_breaking_exception:[parent] Data too large, data for [indices:admin/aliases] would be [2046553436/1.9gb], which is larger than the limit of [2040109465/1.8gb], real usage: [2046552864/1.9gb], new bytes reserved: [572/572b], usages [request=0/0b, fielddata=0/0b, in_flight_requests=786/786b, neural_search=0/0b].
[REQUEST_HANDLING_ERROR_CAUSED_BY] [d0bad391-b80e-445d-89b5-1e506bf6b38a] Caused by: exception: OpenSearchException message: OpenSearch returned an error: Code: 429. Error: circuit_breaking_exception:[parent] Data too large, data for [indices:admin/aliases] would be [2046553436/1.9gb], which is larger than the limit of [2040109465/1.8gb], real usage: [2046552864/1.9gb], new bytes reserved: [572/572b], usages [request=0/0b, fielddata=0/0b, in_flight_requests=786/786b, neural_search=0/0b].

Cause

429 errors from OpenSearch (or ElasticSearch for older versions) suggest that the OpenSearch (or ElasticSearch) service is overwhelmed and struggling to accept all of the information that the Indexer provides. From the logs, the default setting is - 1.8GB in the example above.

Usually, this default setting is set to a percentage of the total memory available for the OpenSearch or ElasticSearch JVM.

See the OpenSearch and ElasticSearch documentation for additional information.

Resolution

To resolve this issue, do either of the following: